Задание 16. Рекурсивные алгоритмы

Звезда не активнаЗвезда не активнаЗвезда не активнаЗвезда не активнаЗвезда не активна
 

ВАРИАНТ 1

Алгоритм вычисления значения функции F(n), где n - целое неотрицательное число, задан следующими соотношениями:

F(n) = 1, при n <= 1;
F(n) = 5 * n + F(n - 1) + F(2),
если n>1 и при этом n нечётно;
F(n) = 3 * F(n - 1),
если n > 1 и при этом n чётно.

Чему равно значение функции F(23)?

Решение и ответ
def F(n):
    if n <= 1: return 1
    if n > 1 and n % 2 == 1: return 5 * n + F(n-1) + F(2)
    if n > 1 and n % 2==0: return 3 * F(n-1)   

print(F(23))

Ответ: 2214271

ВАРИАНТ 2

Алгоритм вычисления значения функции F(n), где n - целое неотрицательное число, задан следующими соотношениями:

F(n) = 1, при n <= 1;
F(n) = 4 * n + F(n - 1) - F(2), 
если n>1 и при этом n нечётно;
F(n) = 3 * F(n - 1), 
если n > 1 и при этом n чётно.

Чему равно значение функции F(35)?

Решение и ответ
def F(n):

    if n <= 1: return 1
    if n > 1 and n % 2 == 1: return 4 * n + F(n-1) - F(2)
    if n > 1 and n % 2==0: return 3* F(n-1)   

print(F(35))

Ответ: 968551148

ВАРИАНТ 3

Алгоритм вычисления значения функции F(n), где n - целое неотрицательное число, задан следующими соотношениями:

F(n) = 1, при n <=1;
F(n) = 3 + F(n - 1) * F(n - 2) - F(n - 1) - F(n - 2), 
если n>1 и при этом n нечётно;
F(n) = 2 * F(n - 1), 
если n > 1 и при этом n чётно.

Чему равно значение функции F(12)?

Решение и ответ
def F(n):
    if n <= 1: return 1
    if n > 1 and n % 2 == 1: return 3 + F(n-1) * F(n-2) - F(n-1) - F(n-2)
    if n > 1 and n % 2 == 0: return 2 * F(n-1)  

print(F(12))

Ответ: 30830260

ВАРИАНТ 4

Алгоритм вычисления значения функции F(n), где n - целое неотрицательное число, задан следующими соотношениями:

F(n) = 2, при n <=1;
F(n) = 1 + F(n - 1) * F(n - 2) - F(n - 1) - F(n - 2), 
если n>1 и при этом n нечётно;
F(n) = 2 * F(n - 1), 
если n > 1 и при этом n чётно.

Чему равно значение функции F(12)?

Решение и ответ
def F(n):
    if n <= 1: return 2
    if n > 1 and n % 2 == 1: return 1 + F(n-1) * F(n-2) - F(n-1) - F(n-2)
    if n > 1 and n % 2 == 0: return 2 * F(n-1)  

print(F(12))

Ответ: 13441735782

ВАРИАНТ 5

Алгоритм вычисления значения функции F(n), где n - целое неотрицательное число, задан следующими соотношениями:

F(n) = 1, при n = 1;
F(n) = n + 2 * F(n - 1) , 
если n чётно;
F(n) = 1 + 3 * F(n - 2), 
если n > 1 и при этом n нечётно.

Чему равно значение функции F(17)?

Решение и ответ
def F(n):
    if n = 1: return 1
    if n % 2 == 0: return n + 2 * F(n-1)
    if n > 1 and n % 2 == 1: return 1 + 3 * F(n-2)  

print(F(17))

Ответ: 9841

ВАРИАНТ 6

Алгоритм вычисления значения функции F(n), где n - целое неотрицательное число, задан следующими соотношениями:

F(n) = 1, при n = 1;
F(n) = n + 3 * F(n - 1) , 
если n чётно;
F(n) = 2 + 2 * F(n - 2), 
если n > 1 и при этом n нечётно.

Чему равно значение функции F(23)?

Решение и ответ
def F(n):
    if n = 1: return 1
    if n % 2 == 0: return n + 3 * F(n-1)
    if n > 1 and n % 2 == 1: return 2 + 2 * F(n-2)  

print(F(23))

Ответ: 6142

ВАРИАНТ 7

Алгоритм вычисления значения функции F(n), где n - целое неотрицательное число, задан следующими соотношениями:

F(n) = 1, при n = 1;
F(n) = n + F(n - 1) , 
если n чётно;
F(n) = 2 * F(n - 1) + F(n-2), 
если n > 1 и при этом n нечётно.

Чему равно значение функции F(20)?

Решение и ответ
def F(n):
    if n = 1: return 1
    if n % 2 == 0: return n + F(n-1)
    if n > 1 and n % 2 == 1: return 2 * F(n-1) + F(n-2)  

print(F(20))

Ответ: 78731

 

Добавить комментарий

РСЯ футер

© 2017 Компьютерный клуб "КОД". Все права защищены.