Задание 17. Поиск в последовательности

Звезда не активнаЗвезда не активнаЗвезда не активнаЗвезда не активнаЗвезда не активна
 

ВАРИАНТ 1

В файле содержится последовательность целых чисел. Элементы последовательности могут принимать целые значения от -10 000 до 10 000 включительно. Определите и запишите в ответе сначала количество пар элементов последовательности, в которых хотя бы одно число является полным квадратом некоторого натурального числа, затем максимальную из сумм элементов таких пар.

В данной задаче под парой подразумевается два идущих подряд элемента последовательности. Например, для последовательности 6, 2, 9, -3, 1 ответом будет  3    11.

Решение и ответ
f=open("17var2.txt", "r")
p= [int(i) for i in f]
f.close()
k=0
PP = -20000
for i in range(len(p)-1):
   if p[i]>0 and p[i]**0.5==int(p[i]**0.5) or p[i+1]>0 and p[i+1]**0.5==int(p[i+1]**0.5):
        k+=1
        PP = max(p[i]+p[i+1], PP)
print(k, PP)


Ответ60     18555

ВАРИАНТ 2

В файле содержится последовательность целых чисел. Элементы последовательности могут принимать целые значения от -10 000 до 10 000 включительно. Определите и запишите в ответе сначала количество пар элементов последовательности, в которых хотя бы одно число является полным квадратом некоторого натурального числа, затем минимальную из сумм элементов таких пар.

В данной задаче под парой подразумевается два идущих подряд элемента последовательности. Например, для последовательности 6, 2, 9, -3, 1 ответом будет  3    -2.

Решение и ответ
f=open("17var2.txt", "r")
p= [int(i) for i in f]
f.close()
k=0
PP = 20000
for i in range(len(p)-1):
   if p[i]>0 and p[i]**0.5==int(p[i]**0.5) or p[i+1]>0 and p[i+1]**0.5==int(p[i+1]**0.5):
        k+=1
        PP = min(p[i]+p[i+1], PP)
print(k, PP)


Ответ: 41    -9786

ВАРИАНТ 3

В файле содержится последовательность целых чисел. Элементы последовательности могут принимать целые значения от -10 000 до 10 000 включительно. Определите и запишите в ответе сначала количество пар элементов последовательности, в которых оба числа делятся на 3, затем максимальную из сумм элементов таких пар.

В данной задаче под парой подразумевается два идущих подряд элемента последовательности. Например, для последовательности 6, 3, 9, -3, 1, 4  ответом будет  3    12.

Решение и ответ
f=open("17var3.txt", "r")
p= [int(i) for i in f]
f.close()
k=0
PP =-20000
for i in range(len(p)-1):
    if p[i]%3==0 and p[i+1]%3==0:
        k+=1
        PP = max(p[i]+p[i+1], PP)
print(k, PP)


Ответ: 562     18033

ВАРИАНТ 4

В файле содержится последовательность целых чисел. Элементы последовательности могут принимать целые значения от -10 000 до 10 000 включительно. Определите и запишите в ответе сначала количество пар элементов последовательности, в которых оба числа делятся на 5, затем минимальную из сумм элементов таких пар.

В данной задаче под парой подразумевается два идущих подряд элемента последовательности. Например, для последовательности из пяти элементов: 5, 25, 125, -5, 1, 4  ответом будет  3    30.

 

Решение и ответ
f=open("17var4.txt", "r")
p= [int(i) for i in f]
f.close()
k=0
PP = 20000
for i in range(len(p)-1):
    if p[i]%5==0 and p[i+1]%5==0:
        k+=1
        PP = min(p[i]+p[i+1], PP)
print(k, PP)


Ответ: 225     -17790

ВАРИАНТ 5

В файле содержится последовательность целых чисел. Элементы последовательности могут принимать целые значения от -10 000 до 10 000 включительно. Определите и запишите в ответе сначала количество пар элементов последовательности, в которых оба числа оканчиваются на 5, затем максимальный из модулей разности элементов таких пар.

В данной задаче под парой подразумевается два идущих подряд элемента последовательности. Например, для последовательности из пяти элементов: 25, 15, 35, -5, 1  ответом будет  3    40.

Решение и ответ
f=open("17var5.txt", "r")
p= [int(i) for i in f]
f.close()       
k=0
PP =-20000
for i in range(len(p)-1):
    if p[i]%10==5 and p[i+1]%10==5:
        k+=1
        PP = max(abs(p[i]-p[i+1]), PP)
print(k, PP)

Ответ: 33    16600

ВАРИАНТ 6

В файле содержится последовательность целых чисел. Элементы последовательности могут принимать целые значения от -10 000 до 10 000 включительно. Определите и запишите в ответе сначала количество пар элементов последовательности, в которых оба числа оканчиваются на цифру 7, затем минимальный из модулей разности элементов таких пар.

В данной задаче под парой подразумевается два идущих подряд элемента последовательности. Например, для последовательности из пяти элементов: 7, 27, 97, -7, 1 ответом будет  3    20.

Решение и ответ
f=open("17var6.txt", "r")

p= [int(i) for i in f]
f.close()       
k=0
PP = 20000
for i in range(len(p)-1):
    if abs(p[i])%10==7 and abs(p[i+1])%10==7:
        k+=1
        PP = min(abs(p[i]-p[i+1]), PP)
print(k, PP)

Ответ: 47    80

ВАРИАНТ 7

В файле содержится последовательность целых чисел. Элементы последовательности могут принимать целые значения от -10 000 до 10 000 включительно. Определите и запишите в ответе сначала количество пар элементов последовательности, в которых оба числа оканчиваются на одну и ту же нечетную цифру, затем максимальное из произведений модулей элементов таких пар.

В данной задаче под парой подразумевается два идущих подряд элемента последовательности. Например, для последовательности из пяти элементов: 1, 21, -11, -3, 1 ответом будет  2    231.

Решение и ответ
f=open("17var7.txt", "r")
p= [int(i) for i in f]
f.close()    
k=0
PP=0
for i in range(len(p)-1):
    if abs(p[i])%10==abs(p[i+1])%10 and abs(p[i])%2==1:
        k+=1
        PP = max(abs(p[i])*abs(p[i+1]), PP)                    

print(k, PP)

Ответ: 227    96784219

 

 

Добавить комментарий

РСЯ футер

© 2017 Компьютерный клуб "КОД". Все права защищены.